Results 1 to 6 of 6

Thread: Bluebeam losing default for PDF

  1. #1
    cphubb Guest

    Default Bluebeam losing default for PDF

    After we upgraded to BB 2016, the default app for PDF has changed every couple weeks from BB to Edge on our Windows 10 machines and XPS viewer on our windows 8.1 machines.

    I this a windows thing or something going on with BB that changes the settings? Kind of annoying when we don't realize its switched and edge tries to open a 400mb 100 sheet drawing set and locks the entire machine while attempting it. We are able to change it back but it keeps resetting.

    Note this never happened on BB 2015 on W10 or W8.1

  2. #2
    Greg Guest


    Hi cphubb,

    How the default application was changed in Windows 8 and again in Windows 10. The intent of the Windows change was to block applications from directly changing the default application. Microsoft sees this as a security issue. Windows will revert to its internal default if it’s been changed directly.

    This means the Bluebeam Administrator alone cannot change the default PDF viewer. Now, some manual interaction is also required on Windows 8.1 and 10 - at least the first time Revu is set as the default.

    I’ve seen the default reset after installing some Windows 10 updates as well as updates to other PDF viewers. But, I don’t recall seeing this recently and haven’t heard users comment on this.

    A visual indicator of the default PDF application is the icon for PDF files. You might consider using the red icon option so it will stand out from the blue Edge icon.

    • Open the Bluebeam Administrator.
    • Click the Revu tab.
    • Change the PDF Icon Color to Red and click OK.

    The Bluebeam Administrator is the only part of Revu that changes the default viewer.

    The following article walks through changing the default PDF viewer:


  3. #3
    cphubb Guest



    It could be updates but I don't think so, at least on the Windows 8.1 machine. Its a shared PC and currently is badly in need of updates, if only people would stop using it for a minute.

    We tried the above setting and it would not stay beyond a reboot so we used the Settings-> default apps-> By File type to make the change and it sticks for a while but then reverts back. Mine did that this morning. However it did NOT change the icon till I had double clicked a PDF and it opened it in Edge. Then all the icons flashed and turned to the E.

    When I manually changed back to BB they also did not change till I double clicked one and even now I still have some that look like the E even though they open with BB.

    As an aside this morning with Edge as the default viewer I checked BB administrator and the Default box was still checked. I clicked OK and nothing happened. It seems to think its the default.

    Just want some way to keep BB as the default PDF viewer. Will also try to get something from MS

  4. #4
    cphubb Guest


    So it looks like this is a MS problem that affects more than BB. It would appear that every time Edge updates it resets the defaults that it controls. Not sure what is going on with 8.1 though, but contacted MS to see what they have to say

  5. #5
    Bill Tillman Guest


    A little late in this post but I too noticed this very annoying revert to Edge as the default PDF viewer. I think it's M$ exerting their control which is one more reason I really hate that OS.

  6. #6
    cphubb Guest


    Quote Originally Posted by Bill Tillman View Post
    A little late in this post but I too noticed this very annoying revert to Edge as the default PDF viewer. I think it's M$ exerting their control which is one more reason I really hate that OS.
    So after an exhausting thread on the MS site. It appears the changing of defaults will only stick until edge decides to take it back. It did this again on Wed. MS cannot say why this happening, and to a certain extent they are denying that it happens at all, because it should not happen given that software cannot take over default in W10.

    One of the posters suggested that the Right click->open with... and choosing the PDF viewer/writer of your choice will permanently fix the issue. I did that yesterday and am waiting to see if it sticks. I'll report back in a few weeks to see if it stays.